Asked May 26th, 4:53 AM 68 0 2
  • 68 0 2
+1

Hỏi về npm

Share
  • 68 0 2

Mọi người cho em hỏi là em bị lỗi gì ạ. em đã thử chạy npm audit fix như hướng dẫn . xóa node_modules, pakage-log.json đi để npm install lại mà vẫn lỗi . thanks

Avatar Nguyen Van Hung @chuothungbang96
May 27th, 1:36 AM

em có thể thử npm audit fix --force xem sao nhé.

0
| Reply
Share

2 ANSWERS


Answered May 26th, 5:17 AM
0

Screenshot from 2021-05-26 12-16-16.png em còn thiếu 2 cái này thôi. nhưng ko pit down sao?

Share
Avatar Khương Nguyễn @nguyenhuukhuong
May 26th, 6:03 AM
May 26th, 6:05 AM

Mấy lần t gặp lỗi kiểu này (không biết có giống y hệt bạn không) nhưng t toàn là version của node ko thích hợp
=> Hay là bạn thử dùng nvm để dùng version khác xem có được không ?

0
| Reply
Share
Avatar Nguyen Nhat @nhatnguyen123321
May 26th, 8:50 AM

do version của node hay npm thế b??

0
| Reply
Share
Avatar Nguyen Nhat @nhatnguyen123321
May 26th, 2:09 PM

@thangnk cho mk hỏi là chuyển version node như nào vậy. hay phải delete down lại

0
| Reply
Share
May 27th, 6:09 AM

@nhatnguyen123321 Bạn có thể sử dụng nvm để control giữa các version của node.

0
| Reply
Share
May 27th, 6:13 AM

@nhatnguyen123321 https://heynode.com/tutorial/install-nodejs-locally-nvm nè bạn. Nhưng hồi trước mình cài là bị chậm hẳn terminal mỗi khi start. Xong mình cứ xài 1 phiên bản stable thôi. Theo mình nó báo lỗi mà code vẫn chạy ngon lành thì cứ kệ nó đi =))) Bạn xài https://www.npmjs.com/package/npm-check-updates xem có thằng nào cần update hay không.

0
| Reply
Share
Answered May 28th, 4:27 AM
0

Theo như ảnh trong câu hỏi thì có phải là lỗi gì đâu bạn.Kia là warning - tức là cảnh báo về các lỗ hổng bảo mật (vulnerabilities) - trong các gói package/dependencices bạn đang cài.

Còn về các lỗ hổng thì như bạn đang làm đấy, chạy lệnh npm audit để xem có những package nào có báo cáo lỗ hổng. Thường thì những lỗ hổng sau khi được báo cáo thì sẽ có sớm các bản vá (patch). Do đó bạn chỉ cần upgrade version của package đó là xong.

Ví dụ như trong ảnh audit bạn comment, thì mình thấy còn 2 report liên quan tới postcssdns-packet. Bạn thử upgrade phiên bản postcss thử xem có hết lỗi không? Lúc upgrade bạn nhớ lưu ý version xem có BREAKING CHANGE ko nhé.

Share
Viblo
Let's register a Viblo Account to get more interesting posts.