Asked Nov 6th, 2018 3:26 AM 99 0 1
  • 99 0 1
+1

vhost trên Ubuntu bị trỏ về domain http://example.com/

Share
  • 99 0 1

Mình đang dùng bản ubuntu 16.04, apache2 và khi mình cấu hình vhost thì bị trỏ về http://example.com/, chỈ có một số project bị, mình dùng php artisan serve thì vẫn ok? ai bị trường hợp này fix thành công rồi thì hướng dẫn mình với

file cấu hình

1 ANSWERS


Answered Nov 6th, 2018 3:29 AM
+1

Chỉ có domain trỏ về server/host thôi chứ bạn. Bạn check xem domain của bạn trỏ về đúng host chưa hay đang cài đặt redirect sang example.com.

Share
Nguyen Tuan Anh @TuanAnh9996
Nov 6th, 2018 3:33 AM

minh đang dùng trên local thôi, hosts mình cũng đã có rồi, mà project này lại bị, những project khác lại không làm sao, mình clone lại về thì nó chết ấy bạn, chứ trước giờ vẫn dùng ok

0
| Reply
Share
Nov 6th, 2018 3:47 AM

@TuanAnh9996 Lỗi này hơi khó hiểu nhỉ? Config vhost thì mình nghĩ là đúng rồi đấy bạn. Bạn đã thử reload vhost bên trên chưa?

0
| Reply
Share
Nguyen Tuan Anh @TuanAnh9996
Nov 6th, 2018 3:50 AM

@huukimit hic, mình reload hết các thể loại rồi 😦(

+1
| Reply
Share
Nguyen Tuan Anh @TuanAnh9996
Nov 6th, 2018 3:54 AM

@huukimit mình xử lý được rồi, do cái domain dev.nafosted.oms, nhưng đang không biết sao cái domain đấy lại bị @@, mặc dù trước khi clone lại vẫn dùng được

+1
| Reply
Share
Nov 6th, 2018 3:58 AM

Mình nghĩ lỗi không phải do apache đâu. Bạn thử:

  • Check thêm config trong /etc/hosts xem đã đầy đủ chưa.
  • Dùng trình duyệt khác xem có bị lỗi như thế không? Xóa luôn cả cache nữa. 😃
  • Check code xem có .htaccess có redirect hoặc code có redirect về trang example không.

Mình cũng đang bó tay với ca này. Hy vọng mấy cách trên mình đưa ra sẽ hữu ích.

+1
| Reply
Share
Nguyen Tuan Anh @TuanAnh9996
Nov 6th, 2018 5:57 AM

@huukimit mình nghĩ có thể do cái .oms, mình bỏ nó đi thì chạy bt, thêm vào thì mới bị

+1
| Reply
Share
Nov 6th, 2018 5:59 AM

@TuanAnh9996 Ra là vậy. Mình hay dùng config dạng *.local hoặc muốn gọn hơn thì dùng *.lc.

0
| Reply
Share
Nguyen Tuan Anh @TuanAnh9996
Nov 6th, 2018 7:11 AM

@huukimit OMG, mình vào http://localhost mà cũng bị luôn

0
| Reply
Share
Nov 13th, 2018 8:33 AM

cái này check lại file /etc/host thôi

+1
| Reply
Share