Asked Apr 22nd, 2020 11:03 a.m. 181 0 1
  • 181 0 1
0

Lỗi update PHP 5.6 lên PHP 7.3

Share
  • 181 0 1

Chào mọi người, mình chạy server CentOS 6.9 và cần nâng cấp PHP lên 7.3 nhưng chạy "yum update" bị lỗi sau. Mong mọi người giúp mình fix lỗi này với ạ. Cám ơn

---> Package phpMyAdmin.noarch 0:5.0.2-2.el6.remi will be an update
--> Processing Dependency: php(language) >= 7.1.3 for package: phpMyAdmin-5.0.2-2.el6.remi.noarch
--> Finished Dependency Resolution
Error: Package: php-symfony4-common-4.1.13-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.1.3
           Installed: php-common-5.6.34-1.el6.remi.x86_64 (@remi-php56)
               php(language) = 5.6.34
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(language) = 5.3.3
           Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
               php(language) = 5.3.3
           Available: php-common-5.4.45-17.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.4.45-18.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.5.38-11.el6.remi.x86_64 (remi-php55)
               php(language) = 5.5.38
           Available: php-common-5.5.38-12.el6.remi.x86_64 (remi-php55)
               php(language) = 5.5.38
Error: Package: php-williamdes-mariadb-mysql-kbs-1.2.10-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.1
           Installed: php-common-5.6.34-1.el6.remi.x86_64 (@remi-php56)
               php(language) = 5.6.34
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(language) = 5.3.3
           Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
               php(language) = 5.3.3
           Available: php-common-5.4.45-17.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.4.45-18.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.5.38-11.el6.remi.x86_64 (remi-php55)
               php(language) = 5.5.38
           Available: php-common-5.5.38-12.el6.remi.x86_64 (remi-php55)
               php(language) = 5.5.38
Error: Package: php-pecl-zip-1.18.2-1.el6.remi.5.5.x86_64 (remi-php55)
           Requires: php(api) = 20121113-64
           Installed: php-common-5.6.34-1.el6.remi.x86_64 (@remi-php56)
               php(api) = 20131106-64
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.45-17.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.45-18.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.5.38-11.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.5.38-12.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
Error: Package: php-phpmyadmin-sql-parser5-5.3.1-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.1
           Installed: php-common-5.6.34-1.el6.remi.x86_64 (@remi-php56)
               php(language) = 5.6.34
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(language) = 5.3.3
           Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
               php(language) = 5.3.3
           Available: php-common-5.4.45-17.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.4.45-18.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.5.38-11.el6.remi.x86_64 (remi-php55)
               php(language) = 5.5.38
           Available: php-common-5.5.38-12.el6.remi.x86_64 (remi-php55)
               php(language) = 5.5.38
Error: Package: php-twig2-2.12.5-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.0
           Installed: php-common-5.6.34-1.el6.remi.x86_64 (@remi-php56)
               php(language) = 5.6.34
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(language) = 5.3.3
           Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
               php(language) = 5.3.3
           Available: php-common-5.4.45-17.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.4.45-18.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.5.38-11.el6.remi.x86_64 (remi-php55)
               php(language) = 5.5.38
           Available: php-common-5.5.38-12.el6.remi.x86_64 (remi-php55)
               php(language) = 5.5.38
Error: Package: phpMyAdmin-5.0.2-2.el6.remi.noarch (remi)
           Requires: php(language) >= 7.1.3
           Installed: php-common-5.6.34-1.el6.remi.x86_64 (@remi-php56)
               php(language) = 5.6.34
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(language) = 5.3.3
           Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
               php(language) = 5.3.3
           Available: php-common-5.4.45-17.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.4.45-18.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.5.38-11.el6.remi.x86_64 (remi-php55)
               php(language) = 5.5.38
           Available: php-common-5.5.38-12.el6.remi.x86_64 (remi-php55)
               php(language) = 5.5.38
Error: Package: php-pecl-zip-1.18.2-1.el6.remi.5.5.x86_64 (remi-php55)
           Requires: php(zend-abi) = 20121212-64
           Installed: php-common-5.6.34-1.el6.remi.x86_64 (@remi-php56)
               php(zend-abi) = 20131226-64
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.45-17.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.45-18.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.5.38-11.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.5.38-12.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

1 ANSWERS


Answered Apr 22nd, 2020 11:21 a.m.
Accepted
+1

Bác phải up version php trước, package đang require php 7.1 nên chưa update được kìa.

--> Processing Dependency: php(language) >= 7.1.3 for package: phpMyAdmin-5.0.2-2.el6.remi.noarch
--> Finished Dependency Resolution
Error: Package: php-symfony4-common-4.1.13-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.1.3
Share
Avatar Kenshei Ou @kenshei1604
Apr 22nd, 2020 12:34 p.m.

vậy bác có thể chỉ giúp mình làm sao update lên 7.1 được không ạ? Mình không biết gì, tự tìm hiểu làm thôi. Nên mong bác chỉ giúp ạ

0
| Reply
Share
Avatar Kenshei Ou @kenshei1604
Apr 22nd, 2020 12:55 p.m.

@dao.thai.son Thanks bạn nha. Mình đã fix được xong và update lên 7.2 rồi. Cám ơn gợi ý của bạn nhiều ^^

0
| Reply
Share
Viblo
Let's register a Viblo Account to get more interesting posts.