Asked Aug 20th, 2018 11:13 AM 181 0 3
  • 181 0 3
0

Lỗi chạy npm run build

Share
  • 181 0 3

Em đang setup môi trường cho 1 project được clone về sau khi chạy npm install. Em có chạy build bằng lệnh npm run build thì bắn ra lỗi

ERROR in ./~/css-loader?{"url":false}!./~/sass-loader/lib/loader.js!./~/postcss-loader!./bower_components/bootstrap-daterangepicker/daterangepicker.css
Module build failed: Error: Node Sass does not yet support your current environment: Linux 64-bit with Unsupported runtime (64)

Em nghi là do version của Node, không biết có đúng không Anh chị cho em xin solution sửa với ạ. Em cảm ơn anh chị.

3 ANSWERS


Answered Aug 21st, 2018 12:21 AM
Accepted
+2

Chắc là do node với npm của bạn rồi, bạn update lên xem sao 😄

Bạn có thể dùng n để quản lý version node trong máy của mình 😄

$ sudo npm install -g n
$ sudo n stable

Sau đó bạn kiểm tra xem version node với npm trong máy mình là gì? (nếu vẫn gặp vấn đề thì bạn gửi luôn thông tin về version node, npm của mình lên đây nhé 😄)

$ npm -v
$ node -v

Sau khi update xong, bạn hãy tiến hành rebuild lại node-sass xem sao 😄

$ npm rebuild node-sass
Share
Answered Aug 21st, 2018 5:19 AM
+2

Nếu bạn đã "nghi" là do version của Node thì ít ra cũng cho mọi người biết là bạn đang dùng version nào, OS nào thì mọi người mới biết đường mà giúp chứ.

Trường hợp của bạn thì có thể là do bạn copy folder node_modules từ đâu đó về thôi chứ lỗi do node version thì nó đã lỗi từ lúc bạn install rồi. Bạn xóa node_modules đi rồi chạy lại npm install xem có được không. Hoặc là npm rebuild node-sass thử xem.

Share
Answered Aug 22nd, 2018 1:35 AM
0

Em cảm ơn mọi người, em đã sửa được rồi ạ. node của em đang 10. em phải down nó xuống node 6.9 rồi xóa node_modules. Sau khi build lại thì đã chạy ngon (tungtang)

Share