Giới thiệu về Mikrotik - RouterOS (phần 1)

1. GIỚI THIỆU VỀ MIKROTIK

Mikrotik-Router.png

1.1 Mikrotik là tên của một nhà sản xuất thiết bị mạng máy tính ở Latvian. Công ty thành lập năm 1995. Sản phẩm chính của công ty là một hệ điều hành dựa trên Linux có tên là Mikrotik RouterOS, được cài đặt trên phần cứng độc quyền của công ty (routerboard) hoặc trên các máy PC bình thường, biến PC đó thành router (nhưng cần mua liscene nếu muốn sử dụng full chức năng) và thực hiện các tính năng của router như firewall, bandwidth, VPN và đầy đủ các tính năng khác của router.

1.2 Để cấu hình Mikrotik ta có 3 cách:

a. Sử dụng phần mềm Winbox được cung cấp trên trang chủ http://www.mikrotik.com/download winbox.PNG

b. Sử dụng trình duyệt web web.PNG

c. Telnet/SSH vào để cấu hình bằng giao diện CLI ssh.PNG

2. CẤU HÌNH MIKROTIK

**2.1 Cấu hình PPPoE cho Mikrotik **

Dịch vụ PPPoE là dịch vụ Point to Point Protocol Over Ethernet được các ISP dùng để cung cấp user/pass cho người sử dụng dịch vụ Internet của họ. Người dùng cần cấu hình PPPoE để được xác thực bởi ISP và đc cung cấp 1 địa chỉ IP WAN để truy cập internet.

Chúng ta vào Interface -> New PPPoE Client PPPoE1.png

Điền tên PPPoE client muốn tạo và chọn cổng Interface chúng ta cắm dây mạng WAN vào. PPPoE2.png

Điền user/pass PPPoE do ISP cung cấp vào PPPoE3.png

Sau khi điền xong ấn Apply và đợi status chuyển sang trạng thái connected thì chúng ta có thể vào tab Status để xem thông tin ip Wan đc cấp là bao nhiêu

PPPoE4.png

Như vây là đã cấu hình xong PPPoE client. Sau đó chú ta cần tạo 1 NAT để cho dữ liệu đi được internet bằng cách vào IP - Firewall - NAT - New

  • Chain: scrnat
  • Out Interface: Cổng ta cắm dây WAN vào
  • Action: masquerade

PPPoE5.png

2.2 Cấu hình DNS

DNS (Domain Name Server) là dịch vụ phân giải từ tên miền sang IP để truy cập internet thay vì phải nhớ dãy địa chỉ IP khô khan, người ta sẽ nhớ các tên miền như vnexpress.net, google.com ... sẽ dễ nhớ hơn. Để biết máy tính đang sử dụng DNS nào ta dùng câu lệnh nslookup

nslookup.PNG

Như hình trên thì DNS hiện tại của máy là 172.16.1.1 và khi phân giải tên miền google.com sễ ra dãy IP

Và bây giờ chúng ta sẽ sử dụng mikrotik để làm DNS server (tất nhiên là nó sẽ ko tốt như 1 DNS server thật) Chúng ta vào IP - DNS dns.PNG

Tại dòng Servers, chúng ta điền ip dns vào, ví dụ ở đây là 8.8.8.8 Ngoài ra chúng ta có thể tự tạo thêm các DNS statis như 1 DNS server bằng cách ấn vào static, chọn dấu + điền vào Name là tên trang web chúng ta muốn phân giải, và điền vào dòng Address IP của trang web muốn phân giải.

2.3 Cấu hình Link Aggregate Group (LAG) hay còn gọi là Bonding

Mô hình vlan và kết nối các switch dùng trunk link đã đạt được mục đích ở khía cạnh business nhưng ở khía cạnh một network admin thì mô hình này không có tính dự phòng. Nếu trunk link mà bị down thì gần như truyền thông giữa các máy tính bị sụp đổ.

Giải pháp cho vấn đề trên là LAG. Đặc điểm của LAG:

High reliability: Down một đường cũng không ảnh hưởng
Redundancy: Có đường dự phòng
Increase bandwidth: Do sử dụng cùng lúc nhiều đường vật lý để truyền thông

Chọn Interface - New - Bonding để cấu hình LAG trên router Mikrotik

bonding.png

Điền tên bonding bạn muốn tạo bonding2.png

Tại dòng Slave chọn các Interface bạn muốn bonding chúng lại với nhau. bonding3.png

2.4 Cấu hình Load Balancing trên Mikrotik

Load balancing là công nghệ giúp chúng ta chạy song song cùng lúc nhiều line WAN khác nhau phục vụ cho mục đích cân bằng tải và dự phòng khi sử dụng dịch vụ internet. Mục đích sử dụng Load Balancing để tăng bandwidth, down một đường cũng không bị ảnh hưởng. Và Mikrotik hỗ trợ rất tốt cho công nghệ này với khả năng Load Balancing một lúc 5 WAN khác nhau. Sau đây mình sẽ giới thiệu cách cấu hình Load Balancing vs 2 line VNPT và FPT bằng giao diện CLI.

Đầu tiên chúng ta cấu hình PPPoE cho 2 cổng e7(vnpt) và e6(fpt) như đã giới thiệu ở mục 2.1 Sau đó chúng ta tiếp tục vào Ip - Firewall - Mangle

/ip firewall mangle
add action=accept chain=prerouting in-interface=e7_vnpt
add action=accept chain=prerouting in-interface=e6_fpt
add action=mark-connection chain=prerouting in-interface=e7_vnpt new-connection-mark=e7_vnpt_conn passthrough=yes
add action=mark-connection chain=prerouting in-interface=e6_fpt new-connection-mark=e6_fpt_conn passthrough=yes
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=bondinge1e2e3 new-connection-mark=e7_vnpt_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=bondinge1e2e3 new-connection-mark=e6_fpt_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=e7_vnpt_conn in-interface=bondinge1e2e3 new-routing-mark=to_e7_vnpt passthrough=yes
add action=mark-routing chain=prerouting connection-mark=e6_fpt_conn in-interface=bondinge1e2e3 new-routing-mark=to_e6_fpt passthrough=yes
add action=mark-routing chain=output connection-mark=e7_vnpt_conn new-routing-mark=to_e7_vnpt passthrough=yes
add action=mark-routing chain=output connection-mark=e6_fpt_conn new-routing-mark=to_e6_fpt passthrough=yes

Tiếp tục vào Ip - Route

/ip route
add check-gateway=ping distance=1 dst-address=0.0.0.0/0 gateway=pppoe_vnpt_e7 routing-mark=to_e7_vnpt scope=30 target-scope=10
add check-gateway=ping distance=1 dst-address=0.0.0.0/0 gateway=pppoe_fpt_e6routing-mark=to_e6_fpt scope=30 target-scope=10

add check-gateway=ping  distance=1 dst-address=0.0.0.0/0 gateway=pppoe_vnpt_e7 scope=30 target-scope=10
add check-gateway=ping  distance=2 dst-address=0.0.0.0/0 gateway=pppoe_fpt_e6 scope=30 target-scope=10

Kết quả sau khi LB xong lb.PNG

Trên đây là 1 vài tính năng sử dụng router Mikrotik-RouterOS, ở phần sau mình sẽ tiếp tục giới thiệu một vài tính năng khác của Mikrotik.